局域网内部语音环境搭建
一.网络拓扑图
二.实验要求
1. 根据网络拓扑图正确配置IP地址和子网掩码,划分VLAN 2. 采用DHCP技术使得IP电话自动获取IP地址和电话号码 3. 10086和10010能够互相电话通讯 三.配置过程 1. SW1:
Switch>ena Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#hos SW1 SW1(config)#vl 100 SW1(config-vlan)#exi SW1(config)#int f 0/1 SW1(config-if)#sw mo tr SW1(config-if)#sw tr all vl all SW1(config-if)#exi
SW1(config)#int r f 0/2-24
SW1(config-if-range)#sw mo acc
SW1(config-if-range)#switchport voice vlan 100 //划分到语音VLAN 100 SW1(config-if-range)#exi SW1(config)#do wr Building configuration... [OK]
2. R1: Router>ena Router#conf t
Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hos R1 R1(config)#int f 0/0
R1(config-if)#no shutdown R1(config-if)#exi R1(config)#int f 0/0.1
R1(config-subif)#enc do 100 //封装802.1Q协议
R1(config-subif)#ip address 192.168.1.254 255.255.255.0 //配置IP地址和子网掩码
R1(config-subif)#no shutdown R1(config-subif)#exi
R1(config)#ip dhcp pool vlan100 //创建DHCP地址池
R1(dhcp-config)#network 192.168.1.0 255.255.255.0 //声明网络号和子网掩码 R1(dhcp-config)#default-router 192.168.1.254 //声明网关 R1(dhcp-config)#op 150 ip 192.168.1.254 //最大获取数 R1(dhcp-config)#exi
R1(config)#telephony-service //进入语音服务配置视图 R1(config-telephony)#max-ephones 2 //最大电话数量 R1(config-telephony)#max-dn 2 //最大电话号码数量
R1(config-telephony)#ip source-address 192.168.1.254 port 2000 //指定源IP地址和端口号
R1(config-telephony)#auto assign 1 to 2 //进行自动匹配1到2 R1(config-telephony)#create cnf-files //建立cnf文件 R1(config-telephony)#exi
R1(config)#ephone-dn 1 //创建第一个电话号码
R1(config-ephone-dn)#number 10086 //指定电话号码为10086 R1(config-ephone-dn)#exi
R1(config)#ephone-dn 2 //创建第二个电话号码
R1(config-ephone-dn)#number 10010 //指定电话号码为10010 R1(config-ephone-dn)#exi
R1(config)#ephone 1 //进入第一个电话配置视图
R1(config-ephone)#mac-address 0050.0F04.4C0C //绑定MAC地址 R1(config-ephone)#type 7960 //指定电话型号
R1(config-ephone)#button 1:1 //进行第一个电话号码匹配 R1(config-ephone)#exi
R1(config)#ephone 2 //进入第二个电话配置视图
R1(config-ephone)#mac-address 0090.2B61.D312 //绑定MAC地址 R1(config-ephone)#type 7960 //指定电话型号
R1(config-ephone)#button 1:2 //进行第二个电话号码匹配 R1(config-ephone)#exi
R1(config)#do wr //保存配置 Building configuration... [OK]
四.配置文件 1. SW1: SW1#sh run
Building configuration...
Current configuration : 2226 bytes !
version 12.2
no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption !
hostname SW1 ! !
spanning-tree mode pvst !
interface FastEthernet0/1 switchport mode trunk !
interface FastEthernet0/2 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/3 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/4 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/5 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/6 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/7 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/8 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/9 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/10 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/11 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/12 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/13 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/14 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/15 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/16 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/17 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/18 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/19 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/20 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/21 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/22 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/23 switchport mode access switchport voice vlan 100 !
interface FastEthernet0/24 switchport mode access switchport voice vlan 100 !
interface GigabitEthernet1/1 !
interface GigabitEthernet1/2 !
interface Vlan1 no ip address shutdown ! !
line con 0 !
line vty 0 4 login
line vty 5 15 login ! ! End
2. R1:
R1(config)#do sh run Building configuration...
Current configuration : 1065 bytes !
version 12.4
no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption !
hostname R1 ! ! ! ! !
ip dhcp pool vlan100
network 192.168.1.0 255.255.255.0 default-router 192.168.1.254 option 150 ip 192.168.1.254 ! ! ! ! ! ! ! ! !
spanning-tree mode pvst ! ! ! !
interface FastEthernet0/0 no ip address duplex auto speed auto !
interface FastEthernet0/0.1 encapsulation dot1Q 100
ip address 192.168.1.254 255.255.255.0 !
interface FastEthernet0/1 no ip address duplex auto speed auto shutdown !
interface Vlan1 no ip address shutdown !
ip classless ! ! ! ! ! ! !
telephony-service max-ephones 2 max-dn 2
ip source-address 192.168.1.254 port 2000 auto assign 1 to 2
create cnf-files version-stamp Jan 01 2002 00:00:00 !
ephone-dn 1 number 10086 !
ephone-dn 2 number 10010 !
ephone 1
device-security-mode none mac-address 0050.0F04.4C0C type 7960 button 1:1 !
ephone 2
device-security-mode none mac-address 0090.2B61.D312 type 7960 button 1:2 !
line con 0
line vty 0 4 login ! ! ! End
五.测试结果
电话10086与电话10010互通